华为设备单臂路由配置

日期:2017-04-11 17:10

部署了VLAN的交换机可以实现在同一广播域内不同主机之间的通信,但是要想实现不同VLAN间主机通信,就要引入路由技术,可以通过二层交换机配合路由器来实现路由转发。

1.首先利用华为模拟器eNSP来设计逻辑网络拓朴图,有一台路由器AR1220,一台二层交换机S3700,二台PC主机。其之间用线缆连接并作好标注。



2.在华为模拟器eNSP中打开终端配置交换机S3700,配置内容截图如下

system-view

sysname SW1 //设置交换机名字为SW1

vlan batch 2 3 //连续创建vlan 2 3

interface Ethernet 0/0/1

port link-type access //设置端口类型为access

port default vlan 2 //将接口划分到vlan 2

quit

interface Ethernet 0/0/2

port link-type access

port default vlan 3

quit

interface Ethernet 0/0/3

port link-type trunk //设置端口类型为trunk

port trunk allow-pass vlan 2 3 //华为交换机默认不支持其他vlan通过,除去vlan 1,允许trunk端口通过vlan 2 3

[SW1-Ethernet0/0/3] //按CTRL+Z返回用户视图

system-view

display vlan //显示vlan

display interface brief //显示接口概

save


3.在打开终端配置路由器AR1220,配置内容截图如下

system-view

sysname R1 //设置路由器名字R1

display interface brief //显示接口概要

interface GigabitEthernet 0/0/0.1

dot1q termination vid 2 //封装dot1q协议,该子接口对应vlan 2

ip address 192.168.2.254 24 //设置子接口IP地址和子网掩码

arp broadcast enable //开启子接口的ARP广播

quit

interface GigabitEthernet 0/0/0.2

dot1q termination vid 3

ip address 192.168.3.254 24

arp broadcast enable

quit

display ip interface brief//显示接口IP的简要状态信息

ping 192.168.2.2

ping 192.168.3.3

quit

save


4.分别在PC1和PC2用ping命令测试连通性,对方收到报文后会反馈时间等信息,如图